Tips : Update Windows secara maksimal dan optimal

email : ariyaandro@gmail.com

tips berikut sebih ditujukan kepada pengguna customer secara umum bukan untuk kalangan server atau windows enterprise.

penulis mulai dari windows 7 saja dan dikarenakan juga sudah hamper semua computer minim  menggunakan win 7, walau win xp masih cukup popular. namun seiring penyerangan virus yang brutal yaitu ransome maka update security patch masih digulirkan pada windows 7 dan xp (khususnya untuk menangkal ransome saja).

perlu diketahui dalam update windows ketika terjadi kegagalan seperti berikut :

gambar. undo update windows 8

maka itu artinya perlu memperhatikan tips berikut agar update pada windows bisa terbarukan dengan baik. berdasarkan gambar di atas menjelaskan bahwa terjadi kegagalan update widnows yang tentunya tidak dijelaskan bagianaman yang menggangu. ini wajar dikarenakan pada windows itu updatenya tidak seperti update pada OS smartphone. jikalau update di smartphone ada poin versi missal da yang terbaru 9.0 sedangkan versi os sebelumnya masih 8.0 dan di antara itu ada versi 8.5 maka biasanya akan dilakukan bertahap hingga versi 8.5 berjalan dengan baik baru versi berikutnya 9.0 akan digulirkan atau di update kan ke smartphone. sedangkan windows lebih memilih untuk download semuanya “Sebisanya” yang belum ada dan melakukan update secara bertahap secara langsung “mungkinnya” maka jangan heran lagi bila kadang di lihat di history update ada yang failed. penulis juga heran kenapa tak diberikan update yang bertahap dahulu seperti di smartphone, atau mungkin ada system yang men-scan perangakt dahulku untuk melakukan penyesuaian dan tahap update lebih bertahap. ok lepas dari segela kebijakan Microsoft yang ada, berikut tips yang perlu dilakukan secara bertahap bila windows tidak mengalami kelancaran update :

  1. important updates
    bila setalah melakukan update sesuai rekomendari windows dan direkomendasikan restart windows, lalu dalam prosesnya terjadi undo update windows seperti gambar di atas maka alangkah baiknya lakukan update widnows ulang namun perhatikan opsi important

    masuklah ke menu list important dan pilih list yang paling krusial terlebih dahulu untuk di update seperti patch security terlebih dahulu diselesaikan semua. semisal seperti gamabr di atas terlihat 14 important itu tak harus semuanya di update terlebih dahulu.

    pilih mulai dari tahap path security update, update windows, update aplikasi internel windows (framework Net), update aplikasi pendukung windows lainnya. bertahap lakukan restart, bila terjadi undo update windows maka missal update security nya sebagian atau perhatikan report date release nya lakukan update pada tanggal yang terlama dahulu. bila dari langka bertahap yang dilakukan misal sudah dipilih update security saja dan tahun terlama saja masih gagal update windows dapat diartikan security pada tangga tersebut sudah include pada update windows sebelumnya (loh kok gak di skip oleh windows ? ya dalam ranah ini Microsoft lebih punya alasannya) maka skip saja update nya pada important security tanggal atau tahun tersebut. hingga semua bertahap update windows important dilakukan semua sesuai pilihan yang telah dilakukan boleh coba update ulang pada path security yang tidak bias dadi sebelumnya (atau skip saja langkah ini dan lanjut dahulu update windows lainnya) bila terjadi gagal update windows lagi, maka sudahilah update important nya. dikarenakan update memang benar-benar tak sesuai di versi atau perangkatnya.
    Windows 10 is receiving important security updates
  2. optional update
    bila langkah pertama sudah sempurna dilakuakn semua walau menyisakan beberapa important itu tidak apa-apa. langkah update selanjutnya yang tentunya opsional, cek saja list optional yang diberikan windows dan perhatikan bagian utamanya seperti di langkah awal yaitu security dulu apakah ada. di langkah ini baiknya pilih misal security dulu sesuai tanggal terlama sesuai label rekomendasi dahulu saja. restart dahulu bisa sudah update security sesuai kebutuhan.
    Windows 10 Tutorials 146 – How to Install an Optional Update
  3. update windows offline
    langkah ini dilakukan bila kedua langkah di atas ada update windows yang besar MB nya atau yang gagal pula ke tika update windows atau patch nya besar untuk di laukan update online.
    dua gambar di atas contoh mencari udapte offline nya pada windows 8.1 dan halaman download nya dari Microsoft.
    Cara Manual Download dan Install Update Windows 10
  4. cek update secara berkala
    pada menu update windows semoga dari 3 langkah di atas untuk masalah update yang tidak lancar ada update yang lebih sesuai nantinya. semoga bila ada patch kbxxxxx yang terbaru lainnya sudah sekalian tertutupi untuk patch sebelumnya tentunya.
    atau mengikuti berita portal widnows baik resmi atau local, atau langsung mencari solusi jika penting untuk update windows patch yang gagal.
  5. setting download update windows
    bagi yang tak suka atau ragu atau takut kemakan quota internetnya, alangkah baiknya pengaturan update windows di setting agar dilakukan pengecekan update saja sehingga nantinya dapat dilakukan udapte secara manual dan sesuai keperluan saja. ingat jangan sampai lupa soal update windows ini dikarenakan tidak akan di downlaodkan langsung dan install langsung.
    Cara Ampuh Mematikan Fitur Windows Update di Windows 10
    6 Cara Update Driver Windows 10 Paling Lengkap
    5 Cara Mematikan Automatic Update di Windows 10 Secara Paksa (Demi Menghemat Kuota Internet)

untuk windows 10 sesuaikan saja tips yang dijabarkan di atas, yang langkah intinya hampir sama dengan point langkah di atas.

7 Hal yang Perlu Kamu Lakukan Setelah Upgrade ke Windows 10 Final

selebihnya silahkan komen, bila ada kurangnya mohon maaf dan selebihnya diusahakan akan direvisi posting ini agar lebih relevan dan tepat sasaran…

salam rekan teknisi seprofesi
__________________________________
link profile teknis penulis

email : ariyaandro@gmail.com

Iklan

Synology : Cloud Station Server on NAS


email : ariyaandro@gmail.com

kali ini penulis akan membahas beberapa fitur baru synology NAS yang mungkin sudah agak lama sudah sekitar setahun yang lalu, namun sepertinya perlu dibahas kembali secara teknis agar lebih jelas dalam melakukan step-by-step fitur Cloud Station ini hingga fitur drive dan office nya synology. dari gambar awal di atas penulis akan lebih membahas 3 bagian perangkat deret bawah yaitu laptop,NAS, dan gadget.

untuk reverensi awal setup cloud station server nya kurang lebihnya dapat melihat beberapa video berikut :

sebenarnya tahap awal yang paling perlu dilakukan adalah register akun ke sinology terlebih dahulu pada link yang di tunjukan waktu proses setup nantinya atau open link nya langsung di  https://account.synology.com/en-global

perlu diperhatikan pada video di atas video ke dua menggunakan DSM 5.x terlihat sedikit berbeda di video ke tiga dengan DSM 6.x, namun intinya sama saja untuk melalukan source dan destination folder cloud pada kedua sisi (client-NAS). mungkin nantinya ada yang aneh pada tampilan awal saat selesai install sinology cloud station, seperti pada beberapa gambar berikut : (hasil gambar dari google tentang cloud station)

dari ketiganya perhatikan deret menu sisi kiri, terdapat beberpa perbedaan dan begitu pulah pulis waktu melakukan uji coba. gambar yang ketiga yang nantinya didapatkan, untuk hal ini penulis masih agak bingung juga, baik di tutorial resmi dan beberpa video test dari orang2 yang sudah mencoba terlebih dahulu. namun intinya, penjelasan yang akan di jabarkan pada postingan kali ini sudah sampai ke tahap cloud station drive, ds cloud, office berjalan dengan baik pada fungsinya semua .

pada tahap awal penulis menggunakan DSM 6.0 dan nantinya akan update ke DSM 6.1 untuk mengeluarkan fitur Synology Drive dan Office nya.

Perhatian !

NAS ini berada di bawahnya perangkat jaringan router dan modem tanpa ada konfigurasi dukungan awal (seperti NAT port router atau DMZ pada modem) sebelum mencoba fitur cloud station ini, dengan susunan/topologi perangkat jaringan seperti berikut :

Internet–>Modem–>Router–>Switch–>NAS-Synology


pertama-tama penulis melakukan cek info center dari NAS terlebih dahulu, akses NAS nya pada jaringan local dan masuk ke control panel lalu tab menu Device Analytics pastikan seperti berikut.

klik “find.synology.com” hingga mengga seperti berikut.

kembali ke control panel NAS, aktifkan quick connect untuk memperolah alamat alias agar nantinya bisa diakses jaringan public/internet.

berikut login Synology account, bagi yang sudah punya akun tinggal login saja baik pada NAS (gambar di atas) dan link akun sinology berikut

https://account.synology.com/

bila sudah masuk ke login ke web akun dari synology (login dan jagan logout dulu) lalu kembali ke posisi control panel dari NAS, di quick connect maka setelah login akun dari NAS maka isi dan sesuaikan penamaan ID quick connect yang di inginkan. hingga seperti berikut

terlihat login akun sinology pada NAS diterima, sedangkan untuk quick connect ID nya bisa disesuaikan keinginan selama tidak ada padanan nama yang sama dalam server synology sana tentunya.

lanjut.. perhatikan sesaat setelah mengisi ID connect maka akan terbuat automatis link akses public-nya dari internet, dimana bila memakai browser sudah ada contoh alamat aksesnya serperti gambar di atas dan link ID nya untuk dari perangkat mobile/smartphone hingga aplikasi pendukungan nanti yang meminta ID quick connect dari Synology NAS nya.

lanjut ke tab login akun synology di lagkah sebelumnya. cek apakah perangkat NAS yang di login pada NAS tadi telah masuk ke list My Devices, berikut daftar NAS yang sudah terhubung juga ke akun dan masuk list.

dapat dilihat bahwa perangkat NAS dengan model yang di loginkan telah masuk daftar di akun. namun dari sini masih ada yang perlu dipastikan lagi, kembali ke setting quick connect dan masuk ke tab menu advanced pastikan hal berikut

untuk mudahnya boleh centang semuanya, bila untuk kebutuhan limitasi bisa diseuaikan kembali missal dengan ID quick connect tidak bisa akses file sharing (koneksi folder sharing) dan web user akses maka bisa menonaktifkan service File Sharing dan DSM.

dari sini sebenarnya sudah bisa dicoba akses NAS dari jaringan luar / internet, coba akses melalui browser sesuai alamat yang di aliaskan di tab menu Quick Connect sebelumnya dan akses alamat DSM nya yang sudah tercantum di gambar langkah sebelumnya. berikut kurang lebih hasilnya bila di akses dari internet yang sama dengan akses NAS dari browser local.

alamat yang diberikan oleh NAS akan di redirect ke alamat lain oleh domain quickconnect dari sinology. dari ini maka untuk membuat NAS diakses oleh public bisa dilakukan.


Langkah Opsional !

langkah ini tak harus dilakukan bila dijaringan masih sesuai keadaan dan kebutuhan awal seperti di terangkan awal di atas. bila jaringan dan NAS berada langsung dibawah modem maka opsi ini untuk kebutuhan direct langsung dari IP public modem ke port NAS. berikut gambaran yang dimaksud

Internet–>Modem–>Switch–>NAS-Synology

maka bila ingin menggunakan ip public dari modem bisa menambahkan setting pada control panel lalu pada menu External Access bisa add DDNS seperti gambar berikut

lalu isi hostname yang diinginkan. bila ada ip public yang static bisa langsung “Set external IP

click OK dan hasilnya seperti berikut

maka hostname dari DDNS yang terbuat bisa digunakan sebagai alias akses ip public modem yang tentunya sudah ada setting direct port atau DMZ yang diberlakukan pada modem (NAS port http 5000, port https 5001).

pada akun juga akan terlihat semakin lengkap data nya

dan jika di coba cek DDNS bisa ping dan hasilnya ip public yang keluar sesuai settingan di External Access

sampai disini sudah cukup setting alias ip publicnya…


selanjutnya adalah membuat user akses ke cloud station yang nantinya untuk koneksi aplikasi service cloud di PC…

sebelum itu buatlah shared folder khusus untuk user cloud misal “Backup-Cloud-Synology“. penulis anggap langkah ini sudah bisa dalam membuatnya. lalu buat folder lagi didalamnya yang nantinya lebih dikhususkan untuk user cloud dan isi beberapa file sehingga nantinya waktu menggunakan synology cloud drive pada PC bisa langsung terlihat ada file yang ter-sync. serikut gambar dari penjelasan singkat pembuatan shared folder nya

lalu buatlah sebuah user untuk koneksi ke fitur synology station ini misal dengan naman “usercloud“. penulis anggap langkah ini sudah bisa dalam membuatnya. maka yang perlu diperhatikan saat membuat atau setelahnya yaitu pastikan properties usernya sesuai kebutuhan berikut pada gambar

sesuaikan permission dan hak akses aplikasinya ini bertujuan agar user yang menggunakan layanan cloud station tidak mengganggu shared folder yang lain.

sehingga bila shared folder dan user akses sudah sesuaikan maka kurang lebihnya hasilnya seperti pada gamabr langkah sebelum yaitu

persiapan folder dan user untuk cloud station secara sederhana sudah dilakukan, maka berlanjut dengan sesi Utama yaitu mulai install cloud station.


Package center

masuk ke package center dan carilah cloud station server dan mulailah install

pasang aplikasinya terserah pada volume Utama atau lainnya, asal jangan sampai lupa klo dipasangnya tidak volume yang lain saja dikhawatirkan ada masalah pada volume yang tak di RAID maka berdampak pada kinerja cloud station server. penulis sengaja mencoba pada volume lain (bukan vol1 Utama) seperti berikut.

click NEXT hingga seperti berikut

click APPLY untuk menyelesaikan tahap install. lalu refresh koneksi ke NAS

lalu buka cloud station server dari menu start nas synologi pada tombol 4 kotak sebelah kiri atas, lalu langsung masuk ke setting untuk penyesuaian lagi. tambahkan akses ke shared folder “Backup-Cloud-Synology” yang dibuat sebelumnnya

sehingga seperti di bawah ini status shared folder Backup-Cloud-Synology

cukup dari sini akan berlanjut ke bagaimana installasi Synology Staion nya untuk client

Synology : Cloud Station Drive/Client on PC

Synology : Cloud Station Client (DS-Cloud) on Android

untuk management user lainnya akan dibuatkan kembali pada posting lanjutan, harap ditunggu…. ^_^

selebihnya silahkan komen, bila ada kurangnya mohon maaf dan selebihnya diusahakan akan direvisi posting ini agar lebih relevan dan tepat sasaran…

salam rekan teknisi seprofesi
__________________________________
link profile teknis penulis

email : ariyaandro@gmail.com

Synology : Sync File NAS dengan akun Google Drive

email : ariyaandro@gmail.com

penulis kali ini akan membagikan pengalaman menggunakan fasilitas atau fitur dari NAS sinology yang bernama “Cloud Sync” yang digunakan untuk mensinkronkan atau menyatukan sebuah/tempat dari suatu tempat lain ke lokasi local maunpun sebaliknya. sync disini bisa 2 arah (saling memadu padankan) atau satu sisi saja (lokasi lokal hanya upload atau download saja pada seluruh atau sebagian).

dalam penggunaannya disini baik untuk kondisi diluar kesibukan jam kerja, misal pada beberapa folder kerja akan di sync di jam tertentu misal selepas jam pulang kantor hingga jam makan malam selesai bisa melanjutkan kerja diluar kantor tentunya (home/café/bad room) . hingga subuh menjelang jam kerja kembali, semua file sudah sync ke device kantor tentunya. itu gambaran kecil kesibukanya, selebihnya sesuaikan dengan fitur setting lanjutan yang ada pada apliaksi “Cloud Sync” ini.

cloud sync ini support hamper semua layanan cloud file storage yang saat ini ada dari google drive, one drive, azure storage, dan lainnya. kalaupun ada layanan baru selain yang dicontohkan disini maka sepertinya hanya berharap untuk update OS NAS dikemudian hari akan segera di support. belum tahu lagi klo memang bisa di add kan manual sejenis API nya ke sini, yang mungkin tak diremondasikan sebelum benar-benar masuk dalam list support layanan apliaksi ini.

untuk mendapatkan dan menjalan kan aplikasi cloud sync ini, silahkan masuk ke NAS sebagai admin atau user akses yang telah diijinkan install aplikasi pada NAS.

silahkan lakukan install “cloud sync” pada package center dari synology

kalua dilihat detail deskripsi aplikasinya bisa menyambungkan beberapa akun berbeda sekaligus atau sesama layanan cloud namun beda akun.

jika cloud sync telah terinstall dengan baik maka akan muncul di start menu NAS, buka dan coba lakukan add akun, pilih layanan yang digunakan…

terlihat beberapa layanan dari consumer hingga enterprise seperti IBM Softlayer, bila dilihat lagi list lengkapnya yang didukung oleh sinology cloud sync ini sudah hingga OpenStack.

lanjut next untuk akses akun terlebih dahulu, kira-kira akan dimintai login akun pada google…

hingga dimintakan ijin terhadap akses google drive yang ada pada akun…

klik allow untuk melanjutkan ijin akses dari apliaksi sinology clud sync. dan dilajut google akan melukan pemastian akses kembali dengan memberikan info perangkat yang mengakses layananya seperti berikut.

klik Agree untuk persetujuan, lalu akan muncul pada windows Utama NAS seperti berikut..

lakukan beberapa penyesuian mulai dari penamaan koneksi (bebas namanya, tidak ada hubungannya dengan google drive). local path yaitu folder local NAS mana yang akan di sync ke google drive nantinya, untuk folder lainnya lagi bisa dilakukan setting selanjutnya nantinya bila tahap add akun ini sudah finish. Remote path yaitu lokasi ek folder mana akan di sync folder local NAS ini, apakah di bagian Utama google drive (terluar drive google / root folder atau di folder tertentu). sync direction yaitu opsi untuk sync yang dipergunakan pada folder yang ditunjuk di google drive khususnya, 2 arah (bidirectional) saling memadupadankan / menyelaraskan / menyamaan dari-ke 2 sisi folder atau sebagai tempat download (folder google drive ke folder local) atau sebagai tempat upload (folder local ke folder google drive). bila ingin diwaktu tertentu bisa melakukan “schedule setting” seperti berikut.

gambar di atas diatur saat-saat tertentu saja dalam melakuan sync agar tak membebankan traffic jam kerja, bila sudah sesuai klik OK. dilanjut pada menu Task Setting sebelumnya untuk Next hingga muncul menu konfirmasi setting berikut.

klik Apply untuk segera melakukan penyelesaian setting. dan pada tampilan Utama cloud sync akan seperti berikut.

terlihat bahwa aplikasi sync cloud akan melakukan sync ke drive google pada nantinya sesuai jadwal sinkronisasi yang akan dilakukan. selebihnya untuk penyesuaian kembali dan add folder sync bisa dilanjut setting pada menu di atasnya.

bila proses sync ke google drive berhasil makan bisa di cek di akun bahwa pada google drive sudah ter-add / terisi folder local NAS. bila nantinya ada perangkat Synology NAS kembali di koneksikan ke akun koneksi ulang dengan Synology Cloud Sync maka selalu akan ada email info bahwa ada perangkat yang masuk ke akun, bila ada perangkat yang tak sesuai sepengetahun dapat dilakuka block di akun goole. berikut contoh email konfirmasi koneksi perangkat yang mengakses layanan dari google.

selebihnya silahkan komen, bila ada kurangnya mohon maaf dan selebihnya diusahakan akan direvisi posting ini agar lebih relevan dan tepat sasaran…

salam rekan teknisi seprofesi
__________________________________
link profile teknis penulis

email : ariyaandro@gmail.com

Troubleshoot : Memanfaatkan/menjadikan Modem-Router bekas telkom Sebagai Wifi Terusan/repeater local

email : ariyaandro@gmail.com

sumber : http://merbabu.com/blog/bisnis-wifi-hotspot/
tipe modem di atas yaitu HUAWEI HG8245A

Post ini ditujukan bagi yang cukup mengerti jaringan minimal pernah ganti2 ip modem atau komputer secara static dan auto/obtain.

Punya modem bekas telkom terutama perangkat indiehome yang sudah dibiarkan oleh telkomnya. Atau ISP sejenis yang meninggalkan modem-router yang didalamnya sudah terdapat fungsi wifi, nah ayo diperdayakan biar tak anggur…

Sebetulnya asal bentuk modemnya seperti contoh gambar di atas, alias ada port LAN dan antena wifi itu merupakan ciri perangkat yang memiliki fitur wifi didalamnya.

Posting ini akan membahas dari segi teknis bagaimana memanfatkan perangkat seperti di atas menjadi jalur ke internet juga via wifi.

poin terpenting dari setting nya yaitu ip LAN dan SSID/penamaan akses poin wifi tersebut.

coba perhatikan susunan diagram berikut, sebelum melanjut postingan ini

NBN_FTTP_Diagram

sumber : https://www.tpg.com.au/support/setup-nbn-fttp/modem-wiring-support.html

biasa nya modem indiehome (diagram : perangkat connection box) terutama port 1 LAN nya (yang di blok warna kuning) di default sebagai sumber internet dan DHCP/ip autometis sekaligus (terlihat di jalur kabel nomer 2), maka fungsi keluaran ini lah yang akan kita olah kembali sebagai wifi terusan/repeater di tempat lain yang mungkin sulit dijangkau oleh wifi modem yang ada di perangkat indiehome.

default port 1 LAN modem sebenarnya bisa diganti dan disesuaikan kembali, misal port 2 dan 3 difungsikan juga sebagai sumber internet dan DHCP. secara settting untuk fungsi tersebut bisa masuk di menu berikut.

anydesk00023

tinggal mencentang port LAN lagi sesuai keinginan, ingat biasanya port 4 digunakan sebagai jalur TV cable/digital dari indiehome. untuk perangkat indiehome lainnya tinggal cari menu yang berhubungan seperti di atas. setelah config/setting di atas di apply maka port tersebut akan berfungsi juga sebagai DHCP. dari keluaran ini terserah mau mengarah lagi ke langsung komputer,router,switch/hub,router wifi, repeater wifi, dsb.

kembali lagi ke gambar diagram di atas, di jalur pengabelan nomer 2 itu menuju suatu router. nah disini kita menggunakan modem lagi yaitu HUAWEI HG8245A. sebelum menggunakannya untuk praktik  disini, maka untuk mudahnya silahkan reset saja perangkatnya dan masuk ke bagian menu LAN dan atur IP yang sekelas/se-subnet dengan modem misal modem ip nya 192.168.1.1 (default setting indiehome). maka pada modem yang di reset tadi sesuaikan misal di ip perangkat khususnya pada LAN IP di setup 192.168.1.200.

anydesk00024

lanjut matikan DHCP perangakat, bertujuan agar IP automatis untuk client nantinya agar langsung dapat dari modem utama yaitu indiehome (bukan dari perangakat indiehome yang telah telah direset ini, dan agat tak saling ganggu dalam memberikan sumber DHCP agar tak saling mengacau) seperti dimenu berikut.

anydesk00025

pastikan enable DHCP atau semacamnya (pada perangkat router wifi seperti ini biasanya berbeda tipe dan merk akan berbeda suguhan menu nya) itu tak tercentang atau disable untuk menu perangkat yang lain.

berlanjut masuk ke menu wifi khususnya pada penamaan dari wifi atau SSID yang dinginkan, sesuaikanlah seperti berikut

anydesk00026

selebihnya untuk pengaturan jenis password sesuaikan dengan selera saja. dan sampai disini pengaturan persiapan pemanfaatan modem bekas sebagai wifi terusan dari modem indiehome utama sudah siap disambungkan seperti diagram di atas di jalur sambungan nomer 2. namun jalur nomer 2 itu masukkan ke bagian port LAN saja yang biasanya warna kuning pula sama dengan modem utama (connection box). kenapa tak sesuai diagram di atas arahannya, bila di sambung ke port yang berwarna biru (WAN port) maka perangkat yang kita gunakan ini tadi akan terpisah dengan jaringan modem utama dan diangkat sebagai sudah masuh jalur internet lalu bila susunan pengabelannya seperti itu maka DHCP server harus dinyalakan agar client mendapat ip tersendiri lagi (sesuaikan subnetnya atau network nya beda ip dengan modem utama agar tak membingungkan perangakat)

sesi pertanyaan :
kenapa setting untuk modem seperti di atas dapat meneruskan koneksi dari router ?
jawaban :
hal ini wajar diakrenakan dalam perangkat dengan fungsi seperti modem-router-wifi atau router-wifi itu antara antena wifi dan port LAN yang ada di setting bridge dan bisa jadi port LAN nya di extensikan ke sebuah antena langsung. jadi berdasarkan teori broadcast maka apapun informasi data yang lewat/masuk pada port LAN dari router/modem lainnya akan diteruskan/di-broadcast ke perangkat yang terkoneksi di perangkat (yang di setting sekarang ini). bahkan walau wifi bekas ini tak berganti ip address dan router merubah ip automatic/DHCP nya maka perangkat yang terkoneksi juga iku dapat ip perubahan walau ip address wifi bekas masih yang sama, kembali lagi itu secara teori broadcast wajar. namun tentunya klo mau mengakses wifi bekas tadi tak bisa lagi menggunakan ip address lawasnya, untuk bypas langsung masih bisa asal laptopnya ikut ip lawasnya wifi bekas.

selebihnya silahkan komen, bila ada kurangnya mohon maaf dan selebihnya diusahakan akan direvisi posting ini agar lebih relevan dan tepat sasaran…

salam rekan teknisi seprofesi
__________________________________

link profile teknis penulis

email : ariyaandro@gmail.com

Troubleshoot : Misteri IP PUBLIC (tidak dapat diakses dari luar/internet)

email : ariyaandro@gmail.com

Ok santai jangan keburu horror sebelum baca semua secara seksama apa sebenarnya ip public dari segi tangan teknisi kita berikut…

mengapa ini dibahas cukup serius padahal teorinya untuk hal ip public itu sudah sangat jelas, walau bagi siswa TKJ khususnya SMK itu sesuatu hal yang tak aneh. nah sebab ini sering dan suka dipercandakan dengan mereka (anak magang SMK) oleh mimin disini, jauh sebelum candaan itu ada tentunya anda yang peka dan aneh/curiga terhadap teori IPv4 itu sangat terbatas dan hingga teori IPv6 yang sempat diibaratkan bisa setiap manusia yang ada sekarang dapat memiliki ip public. namun buktinya hingga postingan ini dibuat belum ada berita darurat IPv4 habis total.

ada beberapa pertanyaan yang terbentuk disini, yaitu:

  1. apakah ip public bisa diakses di manapun ?
  2. lalu apakah benar-benar bisa di akses ip public tersebut dimanapun kita berada ? tentunya di planet bumi
  3. benar pasti kah ip public bisa di akses dimanapun ?

ok, apapun hasil jawabannya diharapakan anda sangat yakin dengan apa yang anda diketahui.

penulis disini akan sedikit menjalaskan dari infrasruktur di bagian end user atau konsumen penikmat internet/inet dan mengambil contoh salah satu paketan ISP negeri kita yaitu paketan indiehome.

secara default modem indiehome dari telkom akan selalu mendapat ip acak setiap menyalakan ulang modem. untuk mengetahui ip acak yang didapat modem dari saluran inet bisa cek di domain ipaddress.com atau yang lainnya yang sejenis untuk menampilkan saluran inet yang didapat memiliki ip berapa. (contoh gambar di atas menunjukan ip yang ada disaluran modem)

bila ip modem telah diketahui dari situs sebelumnya, maka dengan teori ip private atau public pasti kalian sudah bisa menduganya. dari contoh gambar di atas itu bisa dikatakan ip public. nah sebenarnya dari sini sudah terlihat sedikit permasalahnnya. anggap saja dari tempat lain yang sesama pengguna inet indihome untuk melakukan ping saja apakah mau ? bila tidak bisa itu hal wajar, dikarenakan bisa saja pada modem tersebut dilengkapi juga setting block koneksi ping dari luar. dan bila bisa maka anggap saja wajar juga dikarenakan itu ip public dan diperangkat tak dilengkapi anti ping atau semacamnya.

apakah ip acak itu selalu menghasilkan ip public ? secara teori saja itu hak bebas indiehome, asal paketan inet pelanggan tak tengganggu. dan disini sering disalah artikan klo lagi problem modemnya (bila ip public yang dihasilkan oleh modem digunakan untuk kebutuhan sebacam VPN atau akses public atau lainnya). modem seperti itu juga tak harus tertanam atau memiliki ip public baik secara teori atau hukum internet tentunya. untuk keperluan khusus juga penyadia telkom khususnya mempunyai paketan khusus yang bernama telkom astinet yang sudah masuk dalam paketan kategori bisnis. maka bilapun ada bisa memanfaatkan ip public yang di modem indiehome bisa di akses, ingat itu hanya sebatas mengakali atau menyiasaatinya selama dan selama masih bisa disiasati. bila benar2 nantinya tak bisa lagi maka sadarlah bahwa itu paketan hanya untuk jaminan akses internet, selebihnya harus masuk bisnis.

apakah ip acar tersebut pasti selalu ip public ? secara teori penyetingan itu bisa dan sah-sah saja. maka jangan heran bila kadang sesaat ip pada WAN modem tak sama dengan cek ipaddress.com yang ada. sekali lagi itu sah dalam paketan yang hanya menjamin jalur inet anda (sederhananya selama masih bisa buka mbah google, maka inet paketan anda normal) maka sebaik2 nya pengguna harap lebih mewajari. secara teori yang lainnya bila modem mendapat ip public pada WAN sama juga apa yang di hasilkan cek ipaddress.com maka itu boleh dan tak apa2 secara dunia inet (asal google masih bisa akses). nah biasanya pada indiehome hal ip public yang di cek di ipaddress.com tak sama pada status WAN dimodem, hal itu biasanya berlangsung beberapa saat dan biasanya pula hanya cukup di restart saja modemnya namun bila pun masih tak sesuai status WAN dengan cek dari ipaddress.com dalam sehari atau dua hari melakukan restart modem kembali masalah ini bisa kembali normal mendapat ip public yang sesuai kembali. dan selalu ingat kembali ini hal biasa dan boleh2 saja dilakukan siapapun profider inet nya, dan paketan indiehome tak ada jaminan untuk ip public static.

penulis kembali lagi ke teori ip public (baik static ataupun tidak) bila ada misteri ip public tak bisa di akses dengan mudah di manapun maka harap langsung periksa falitas paketan yang pasti dari layanan anda terima dari profider. dan jangan menjadi pelanggan yang terlalu konyol walau bahasa anda lebih pandai secara suara. baik berikut sedikit uraian teknisnya :

  1. ip public static setidaknya bisa diakses senasional khususnya indonesia, dan mau tak mau pasti di kontrak ip public tak ada jaminan ip public static khususnya itu bisa di akses di beda benua misal eropa ke indo. kok bisa begitu ? itu masih wajar, kembali ke teori bahwa cadangan ip public tak banyak dan profider apapun tentunya tak muda mendapat ijin dagang ip public dan share ke yang lain. maka bila ada kebutuha seperti itu maka sejak dari awal haruslah pesen sesuai kebutuhan sekarang dan kedepan sekalian. soalnya tarif ip public dengan penuh akses dimanapun itu tak semurah ip public nasional. dari sini tetap fokus mengambil asumsi bahwa tak seharusnya merasa bermasalah bila akses dari eropa misal tak bisa, sembari mengingat bahwa kebutuhan secara lokasi saja harus di omongkan di depan juga. toh soal keperluan akses dari lokasi jauh tak harus mengerti jaringan komputer atau paket penjualan dari si profider kan, cukup deskripsikan keperluan yang diperlukan sebisanya (syukur2 ada teman IT yang cukup mengerit pula dengan kebutuhan anda)
  2. ip public dynamic (acak), ip yang tertanam di modem seperti ini perlu sedikit dipahami oleh anak baru IT. dalam dunia jaringan khususnya bab routing nantinya akan mengenal config/setting “OSPF area”, kebayangkan bila beberapa area biasanya sulit di akses atau tiba2 sulit diakses. ini masih dugaan dalam bahasan ini soal area tersebut, namun walau pengguna tanya kepada Call center tentunya itu bukan hal yang harus di jawab dan di publish. dimana setiap permasalahan inet akan difokuskan kembali dengan keperluan dan fitur paketan yang dibeli. terkadang misal pada daerah tertentu yang berjauhan (nasional) bisa diakses kembali. dan terkadang dengan restart modem daerah lain bisa mengakses kembali, bila kembali sulit lagi maka sadarlah itu masih terkait dengan paketan indiehome yang tergunakan saat ini.

sekiranya penulis dari sini, diharapkan pengguna bukan semakin menyalahkan dan bukan berarti apa adanya. hal seperti ini juga tak lepas dari “cerdaslah dalam membeli”, so saling memahamkan secara umum tidak salahnya juga agar tercapai kesepahaman yang saling mendukung.

selebinya silahkan komen, bila ada kurangnya mohon maaf dan selebihnya diusahakan akan direvisi posting ini agar lebih relevan dan tepat sasaran…

 

salam rekan teknisi seprofesi
__________________________________

link profile teknis penulis


email : ariyaandro@gmail.com

Troubleshoot : Load Balancing Mikrotik – Nth (2 WAN balancing – 1 WAN direct – with 2 LAN Subnet)

email : ariyaandro@gmail.com

sumber : https://forum.peplink.com/t/deploying-the-peplink-balance-in-drop-in-mode/8030

Post ini ditujukan bagi yang sudah mengerti jaringan mikrotik pernah setting basic seperti DHCP server dan pembagian bandwidth secara merata menggunakan mirkotik. Post ini akan fokus langsung ke mangle dan routing…

Posting ini akan membahas sedikit hal teknis tentang permasalahan judul di atas. Berawal dari kebutuhan dan beberapa posting blog lainnya juga, maka ingin memperjelas sedikit temuan masalahnya. Yang dengan skenario brikut dan temuan di internet umumnya ternyata dalam awal load balancing yang berjalan dilanjut penambahan dan pemisahan jalur jadinya terjadi berikut :

  1. 2 modem indiehome tergabung dalam satu mikrotik
  2. 2 modem di atas di mode kan load balancing
  3. Metode balancing dengan Nth
  4. Semua jalur LAN hanya melalui satu port mikrotik saja
  5. Dilanjut penambahan 1 modem ISP lainnya yang dipruntukan kebutuhan khusus

Maka lanjut salah satu opsi yang di ambil,

  1. Port LAN di modekan DHCP server
  2. Sedangkan untuk kebutuhan khusus di modekan jalur ip static koneksi LAN nya

nah akhirnya masalah yang timbul dari skenario di atas adalah disaat dimana kebutuhan terbaru yaitu point 5 “penambahan 1 modem ISP lainnya yang dipruntukan kebutuhan khusus“. dari beberapa tutorial hasil pencarian di internet dengan kata kunci “memisahkan 3 lan dengan 3 isp” maka terlihat dari beberapa tutorial hampir sama semua tekniknya walau tak sama persis dengan skenario. namun dari segi teori dari beberapa artikel tersebut terlihat baik2 saja dan sesuai teori baik yang menggunakan metode prerouting atau input-output dalam pengaturan mangle nya.

ternyata permasalahnya dilapangan (yang didapat dari salah satu artikel, maaf tak sempat untuk save) masih kurang sesuai yang diinginkan. ada sedikit perbedaan dari lainnya yaitu penggunaan Passthrough di metode prerouting, yang tentunya untuk kases skenario di atas ini ternyata memfungsikan pembagian dan pengalihan dalam mengarahkan koneksi routing dari ip tertentu (kebutuhan khusus) ke ISP yang di inginkan sebelum koneksi tersebut terpilah oleh mangle load balancing Nth.

ok berikut gambaran topologi dari skenario di atas :

Drawing1

keterangan gambar :
di asumsikan ether1 untuk telkom1 (ip : 192.168.100.0/24)
ether2 untuk telkom2 (ip : 192.168.200.0/24)
ether3 untuk ISP3 (ip : ip-public-static/30)
ether4 untuk jalur local (ip : 192.168.1.0/24)

SESI 1

pada mulanya menggunakan load balancing 2 modem telkom (belum ada ISP ke 3) dengan mangle untuk memisahkan jalur ke dua modem seperti berikut :

buat list address terlebih dahulu sesuai kebutuhan

/ip firewall address-list
add address=172.16.1.0/24 list=Server
add address=10.0.0.0/24 list=Server

lalu filter koneksi untuk pemisahan ke dua modem, dengan ketentuan selain list server akan di anggap koneksi yang akan ke modem

/ip firewall mangle
add action=mark-connection chain=prerouting comment=\
 "LB-Nth__________ kecuali menuju server list" connection-state=new \
 dst-address-list=!Server in-interface=ether4 new-connection-mark=satu \
 nth=2,1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=satu \
 dst-address-list=!Server in-interface=ether4 new-routing-mark=na_WAN1 \
 passthrough=no
add action=mark-connection chain=prerouting connection-state=new \
 dst-address-list=!Server in-interface=ether4 new-connection-mark=dua \
 nth=1,1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=dua \
 dst-address-list=!Server in-interface=ether4 new-routing-mark=na_WAN2 \
 passthrough=no

dilanjut dengan penentuan mangle masuk ke modem mana saja

/ip route
add comment=LB-Nth distance=1 gateway=192.168.100.1 routing-mark=na_WAN1
add distance=1 gateway=192.168.200.1 routing-mark=na_WAN2
add check-gateway=ping comment=utama distance=1 gateway=192.168.100.1
add check-gateway=ping comment=cadangan distance=2 gateway=192.168.200.1

seharusnya sampai disini potongan script utama sudah bisa menjalankan load balancing dijaringan local

SESI 2

ada penambahan ISP ke 3 dan diperuntukan bagi yang menggunakan menggunakan ip static, agar terpisah dari jalur local yang ada yaitu 192.168.1.0/24. namun berhubung setting mangle sebelumnya diperuntukkan selain list serve maka akan kena mangle load balancing maka dicoba disiati pembuatan mangle lagi untuk ip static tersendiri yaitu 192.168.11.0/24 agar dilewatkan saja jalur internetnya ke ISP3. maka dicobakan script berikut

buat list address kembali ini local static

/ip firewall address-list
add address=192.168.11.0/24 list=Khusus-Hyper

penambahan mangle, namun letakkan pada urutan sebelum mangle load balancing

/ip firewall mangle
add action=mark-connection chain=prerouting \
connection-state=new in-interface=ether4 \
new-connection-mark=conn_hyper passthrough=yes src-address-list=\
Khusus-Hyper add action=mark-routing chain=prerouting connection-mark=conn_hyper \
new-routing-mark=to_hyper passthrough=no src-address-list=Khusus-Hyper

penambahan routing, ditandai dengan distance ke 3 saja seperti berikut

/ip route
add comment=cadangan-hyper disabled=yes distance=3 gateway=113.110.12.57 \
routing-mark=to_hyper

secara lapangan waktu dicobakan jalan ip static memperoleh jalur ke ISP3 dan berhasil dipisah dengan kedua modem telkom.

bila terjadi problem

coba rubah distance jalur telkom pada tabel routing di beri angka 2 dan ISP3 sebagai utama dengan memberi angka distance 1.

jika bermasalah kembali, ini temuan yang belum tercoba ( mungkin klo sempat coba hasilnya akan di ubdate ) yaitu dengan cara mangle untuk memisahkan jalur ke ISP 3 itu disable saja dan routing tabel menjadi 2 modem telkom distance 2 dan ISP3 dengan distance 1 non routing mark (kosongi)

selebihnya silahkan komen, bila ada kurangnya mohon maaf dan selebihnya diusahakan akan direvisi posting ini agar lebih relevan dan tepat sasaran…

 

salam rekan teknisi seprofesi
__________________________________

link profile teknis penulis


email : ariyaandro@gmail.com

Docker : melihat teknis kerjanya membangun container

email : ariyaandro@gmail.com

sebelum memulai membaca apa yang akan di gambarkan apa itu docker secara teknis dalam mambangun suatu container, alangkah baiknya sudah mengerti dan sedikit paham mengenai hal berikut :

  1. Virtual Machine (VM)
  2. Komputer Client – Server
  3. web server
  4. OOP (Object Oriented Programming)

Docker merupakan project open source yang menyediakan platform terbuka untuk developer maupun sysadmin untuk dapat membangun, membundel dan menjalankan aplikasi dimanapun dalam satu container yang ringan. Mirip seperti Virtual Machine (VM) namun lebih ringan karena Docker tidak membawa keseluruhan sistem operasi, melainkan berbagi sistem dengan host induknya.


lalu untuk pembuka gambaran docker bisa juga baca2 link berikut, dalam penyajian presentasinya cukup menarik dan simple :

https://xebia.github.io/twc-cd-with-docker/#/

untuk melihat gaya perintah dalam menggunakan docker untuk memfungsikan container, bisa dibaca juga link berikut :

https://blog.jayway.com/2015/03/21/a-not-very-short-introduction-to-docker/

sedikit ulasan berbahasa indonesianya bisa dari link berikut yang cukup enak bahasannnya :

https://blog.andi.dirgantara.co/teknologi-kontainer-pengantar-pengenalan-docker-706eafe03269

container yang akan dibahas ini adalah container yang berjalan di docker dengan VM desktop yaitu pada Virtual Box, yang mengambil basis pada windows. direkomendarikan menggunakan komputer atau laptop yang belum ada Virtual Box dan Docker yang terinstall sebelumnya. klo sudah sih tak apa, disini akan digambarkan sedikit demi sedikit penjelasan bagaimana container ini bisa jalan dan aktif siap digunakan secara sederhana.

sebagai pembuka, berikut gambaran teknis berdasarkan diagram proses docker container yang umum di internet dan kemudian di asumsikan oleh postingan ini secara teknis. dan tentunya tak terlepas dari saling koreksi selanjutnya, berikut gambaran sementara teknis dari docker :

gambar 1. diagram client-server dari container (in VMware) dan bukan container (in VBox)

bagaimana ? jadi salah expetasikah dengan hasil gambar dari hasil pencarian di internet dengan kata kunci “docker container

ok untuk jawabannya akan di tulis secara berkelanjutan lagi oleh mimin ya kakak. mimin juga sedang belajar docker ini dan memastikan pemahaman teknisnya dikarenakan masih sedikit sekali yang meruncing bahasan tentang segi teknis dari teknologi container ini khususnya di docker.

dari gambar 1 penulis mencoba untuk menterjemahkan sedikit demi sedikit bagaimana dan di mana proses suatu container terbentuk. pada umumnya system container digambarkan seperti diagram berikut.

lxc_2D00_vm

gambar 2. antara VM dan Container

sedikit info yang belum tahu dari gambar 2 di atas hypervisor dan VMware merupakan programs yang sama dalam membangun suatu VM. dapat diperhatikan bahwa sepertinya pada saat terbentuknya container tidak ada guest OS yang berjalan atau yang tergunakan, dengan langsung menuju ke binary/library yang ada di atas Host OS. untuk binary/library dan app itu sudah masuk dalam wilayah container, seperti berikut :

gamba 3. letak conrainer

dalam diagram gambar 2 tersebut wajar tak tergambarkan guest OS di container dikarenakan dalam system container tidak diperlukan system OS seutuhnya seperti loading booting, berbagai macam system pembangun ketika desktop os pertama up untuk siap digunakan kerja dan sebagainya secara penuh. namun container hanya memanfaatkan fungsi-fungsi penting dalam menjalankan suatu programs dalam suatu OS yang dapat diibaratkan ada VM/virtual machine windows server tanpa perlengkapan system32 secara penuh dalam membangun OS yang siap di operasinalkan hanya ada system pendukung penuh untuk segala aplikasi di “programs file”. maka pada gambar 2 dan 3 penulis sesuaikan lagi secara teknis pada gambar 1 di atas, dimana sebenarnya masih ada dan butuh system OS (seperti kutipan text hijau di awal postingan ini dan penjelasan dari yang lain tentang docker membangun container).

penulis mengambil proses pembentukan suatu container dari sisi aplikasi virtual mesin desktop yaitu Virtual Box, namun secara basic semua aplikasi/program VM itu bertujuan sama mensimulasikan OS secara virtual. dalam vmware terlihat dalam mambangun banyak aplikasi maka bisa membuat sebuah VM yang nantinya di dalam VM tersebut dijejali banyak aplikasi sesuai kebutuhan. namun untuk aplikasi dengan lintas OS (dari web server ubuntu ke fedora) tentunya akan membuat VM satu kembali dimana config VM untuk OS lainnya di miripkan atau sama dengan VM yang pertama tentunya walau OS nya berbeda dan dari segi aplikasi biasanya service antar lintas OS tentunya tak akan sama atau minimal mirip dikarenakan standard dari setiap OS berbeda dalam menjalankan prosedur aplikasinya. walau sebenarnya dengan cara clone VM sudah bisa membuat web server ulang dengan kelengkapannya kembali dengan resource yang hampir sama atau lebih ditinggikan kembali, dari sini teknologi container mengambil celahnya. berikut gambaran container pada docker :

gambar 4. container on docker

suatu container tidak harus membutuhkan config resource virtual mesin yang seperti di PC yang ada OS sepenuhnya. container diciptakan agar menggunakan resource serendahnya dan seperlunya saja, yang tentunya sudah terpangkas tak menggunakan system OS sepenuhnya. jikalau pada PC atau VM pada umumnya sebelum ada container ini, setiap VM itu dalam membangun OS nya harus ada file .ISO sebagai installer OS nya dan master aplikasi untuk di install. namun container tidak sepenuhnya seperti itu, dalam menjalankannya ini hanya me-read system OS (image.tar) dan terbentuklah container bedasarkan image yang di load di dalam system docker. sebenarnya image.tar ini seperti me-remastering linux sesuai kebutuhan khusus yang diinginkan dan mengemas ulang ke .ISO misal Linux Mint yang basisnya dari ubuntu. berikut kurang lebihnya bila image.tar dibedah.

gambar 5. dalam file image.tar

dapat sedikit dipahami kembali dari gambar 1 hingga 5 ini bahwa container ini sebenarnya ada system OS pendukung yang di sertakan walau tak selengkap dan power full dengan OS installer sepenuhnya pada desktop user. dan perlu diperhatikan bahwa image.tar debian di atas hanya sebesar sekitar 100 MB saja. cakep bukan 🙂

dari image.tar itu akan di read oleh container dan segala perubahan ada disimpan tersendiri pada data disk yang tercitak dalam docker berdasarkan per container yang terbentuk dalam docker di VM nya. maka dari dapt dijelaskan bahwa sebuah image container bisa dan boleh di akses oleh banyak container dengan tujuan berbeda-beda seperti berikut.

gambar 6. sistem barbagi image di container

dan dari beberapa gambar di atas dapat disimpulakan kembali seperti gambar berikut dalam melihat posisi kembali container pada docker.

gambar 7. containers_versus_virtual_machines


dari sini silahkan install dulu docker di windows, berikut link video install docker pada windows ( https://www.youtube.com/watch?v=3IEvmCYjdRc )

yang hasil install docker akan muncul 3 icon seperti pada gambar 8 di bawah ini yaitu VirtualBox, Kitematic,Docker QuickStart.

 

anydesk00027

gambar 8.properties VM docker container

VirtualBox disini akan ada vm default secara langsung merupakan vm dari docker yang tercipta saat proses instaasi docker tools.

Kitematic akan digunakan sebagai tool GUI untuk download registry dan setup docker nantinya secara sederhana pada windows. dimana di saat membuka tool ini akan langsung up kan vm docker di virtual box, dan nantinya akan sekaligus konek ke store domain docker.

gambar 9. startup kitematic

gambar 10. dashboard kitematic

dari menu gambar 10 di atas ada “My images” disitulah akan menampilkan daftar image container yang telah ter-downlaod yaitu image.tar.

Docker QuickStart sebuah jembatan terminal antara terminal/console pada vm docker yang sedang berjalan. dimana di saat membuka tool ini akan langsung up kan vm docker di virtual box, dan selebihnya bias manage docker dari sini untuk lebih advanced nya.

gambar 11. docker terminal

docker ini sebenarnya berjalan di dalam suatu VM (dalam hal ini dalam paket installernya menggunakan vm desktop yaitu VirtualBox) di mana file docker.iso (file sebenarnya boot2docker.iso) akan di load saat proses booting vm berjalan live (jadi bila didalamnya ada perubahan maka akan terhapus bila docker di booting ulang dalam VM). berikut isi folder VM docker yang tercipta

gamabr 9. isi folder vm docker pada windows

coba lihat setting properties dari VM docker (nama vm nya “defaut”) dalam virtual box agar semakin paham yang di maksud. terlihat bahwa ada disk virtual yang terbuat dan bila nantinya sudah ada image container dan container yang berdiri di dalam (disk.vmdk) docker maka disk tersebut akan membengkak seperti contoh di gambar 9. dan berdasarkan gambar 1 yaitu pada bagian drive (kotak orange) di dalam VM docker itulah disk.vmdk yang penulis maksud. jadi penggambaran docker selanjutnya seperti berikut.

gambar 10. digram berbagi service antar container

berikut hasil bila ada container yang sedang running, info IP dan Port dari suatu container akan dimunculkan sesuai fungsi dari container yang sudah di download yang artinya bila yang di ambil adalah container web server (nginx misalnya) maka akan ada info akses port ke 80 dari container tesebut dengan alias akses port random yang di infokan tentunya.

gambar 11. container running dan akses terminal suatu container

dari gambar 11 di atas terlihat bahwa container masih di sertakan folder persis seperti sebuah OS Linux utuh, sesuai bahasan teori teknis sebelumnya. sedikit catatan bahwa ketika kitematic ini di close, container masih dalam ke adaaan running dan bila semua container off VM docker tetaplah up juga. tapi tenang itu cuman setting di kitematic nya saja, jadi bisa di sesuaikan nantinya. dan dapat di akses pula container melalui terminal dari tombol menu EXEC dan akan di link openkan ke shell windows. dari shell terminal itu bisa dijalankan perintah Linux pada umumnya, namun bila menjalankan perintah shutdown Linux yaitu “init 0” seperti gambar di bawah ini maka pada container di dastboard kitematic masih terlihat running walau nantinya shell terminal nya akan close (bisa dibuka kembali dengan menekan kembali tombol EXEC). dari init 0 tadi terlihat bahwa system os tidak jalan seutuhnya sesuai konsep container, begitu pula perintah system lainnya yang biasanya ada pada OS desktop maupun Linux server yaitu make. berikut hasil eksekusi perintah Linux nya.

gambar 12. akses telminal container linux

gambaran port akses dari suatu contain dapat di lihat seperti berikut.

gambar 13. akses port container

coba stop dan start kembalilah container dari dashboard kitematic, butuh berapa detik ? nah itulah container ia hanya up langsung seperti maount sebuah file iso, dikarenakan image.tar saat di container kan ia hanya eksekusi langsung apa-apa yang ada di fungsi image tersebut.

munkin sementara itu penelasan teknisnya, lain waktu mngkin ada revisi kembali di posting ini setelah explore docker di kesempatan lainnya….


secara pandangan penulis ilmu container docker ini terletak pada tingkat/urutan/tahapan ilmu seperti berikut kurang lebihnya:

  1. komputer (pengertian umum)
  2. cara merakit PC (rakitan)
  3. operating system (Linux,windows,solaris,dkk)
  4. aplikasi server (apache,mysql,dkk)
  5. networking (routing,firewall)
  6. virtual mesin (Vbox,VMware,HyperV,dkk)
  7. container (LXC,docker,dkk)

jadi biar tak bingung masuk bab container ini, tentunya ilmu yang tersampaikan itu baik ketika pada waktunya.

 

selebihnya silahkan komen, bila ada kurangnya mohon maaf dan selebihnya diusahakan akan direvisi posting ini agar lebih relevan dan tepat sasaran…

salam rekan teknisi seprofesi
__________________________________

link profile teknis penulis

email : ariyaandro@gmail.com

%d blogger menyukai ini: